Felipe Roman’s Weblog

“Sólo Dios es el verdadero sabio.” Sócrates.

Problemas con el servicio HUB Transport en Exchange 2007

Resulta que tuve que darle soporte a un servidor de Exchange 2007, con el rol de Hub Transport. Aparecía el siguiente error en la bitácora:

event-2142

Por este problema: “Topology discovery failed”, el servicio de Transport no podía arrancar.

Luego de investigar un rato, la causa no parecía andar por Exchange 2007, sino en los permisos en AD.

 

Localicé estas 3 posibles causas:

1. Podría deberse  a falta de permisos de la cuenta del servidor de Exchange, para acceder la info en AD.

“This problem occurs because the Exchange security groups do not have the appropriate user rights to enable the Directory Service Access (DSAccess) component to communicate with Active Directory.”

La solución está documentada en el siguiente link: http://support.microsoft.com/kb/919089/en-us, aunque este artículo es para Exchange 2000 y 2003, creo que igual vale la pena verificarlo. Este otro link se refiere al mismo tema: http://www.chapleau.info/cs/blogs/fchapleau/archive/2006/02/12/63.aspx#597.

2. Otra posibilidad es que el servidor de Exchange esté en una subred no asignada a un site de AD.

Acá se muestra parte de la solución: http://www.eggheadcafe.com/conversation.aspx?messageid=30701959&threadid=30690963.

3. En esta otra posibilidad hacen referencia al Rollup 8 de Exchange: http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/1b0191f0-ffba-48f5-8249-a0236b3dbf6a/.

 

Para no cansarlos con la historia, la solución estaba en la opción #1. Sucede que el proceso de preparación del AD para Exchange 2007 y de instalación del servidor, deberían haber incluido la cuenta de computadora del servidor de Exchange dentro del grupo: Exchange Domain Servers, que a su vez es parte del grupo: Exchange Enterprise Servers.

Este último grupo es el que cuenta con permisos para: “Manage auditing and security logs” en la GPO: Default Domain Controllers Policy, necesarios para realizar el descubrimiento de la topología.

En mi caso, como les repito, la opción correcta era la 1, pero es importante validar las restantes con tal de corregir.

Espero que esto les ayude.

Dejen sus comentarios.

Felipe Román

4 agosto, 2009 - Posted by | Active Directory, Exchange, Soporte

Aún no hay comentarios.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: